Lea 0

I have a dl tag, and inside it there is a dd tag, in which I put an a tag with a link. However when I click the link - nothing happens. I tried right-clicking "open in new tag" and that works. What could the problem be?

  • Is the problem on the page for which you've provided the screenshot? Can you identify which specific link is causing the problem as they all seem to work okay for me in Firefox 3.6 John Catterfeld about 6 years ago

2 answers

0
points
This was chosen as the best answer

Sorry, I found the link you were referring to and also get the problem, but can't edit my comment above. The issue is a javascript conflict as the links work as they should with JS disabled so have a close look at your script.

Answered about 6 years ago by John Catterfeld
  • Thank you. Your answer helped in that we looked in the comments on the site from which the code was taken http://css-tricks.com/grid-accordion-with-jquery/, and there it said that jQuery "steals" the clicks. A small correction fixed the problem. Lea about 6 years ago
0
points

The inactive tag is not a link, if I am looking at the correct one (The link in the first button of the third column from the right).You should have pointed out which link you are referring too. A comment on your programming style: There was really no need of using the tag in your links. You could have had them in the style property of the itself. Further, the use of tag is not recommended as its use is deprecated. It is supposed to be removed in a future version of HTML.

Answered about 6 years ago by Aakash Bhowmick
  • This is code copied from somewhere else, and it worked there. Lea about 6 years ago