Hi there

I have a question regarding the history plugin and jQuery Tools v. 1.1.2. I currently use the tabs plugin, and would very much like to have some kind of history-functionality. I need this so that I can link directly to one of my tabs. I do only work with version 1.1.2 of jQuery Tools, because the 1.2.0 version conflicts with some of my other javascript. This means that I need to be able to link directly to my tabs with version 1.1.2 of Tools.

Right now my script looks like this:

$("ul.plan-tabs").tabs("div.plan-panes div.fane", { tabs: 'li'});

But I can't find any way to link directly to my tabs. Nomatter wich id(#) I puts in my URL, I always gets the first tab :(

Can anyone help?

Thanks a lot in advance.

/Kim

1 answer

Mottie 1134
0
points

It appears that version 1.2.0 and above supports the history plugin (ref):

history - Since 1.2.0. Enables support for browser's "back button" so that when a user clicks on the back or forward buttons the tabs are opened accordingly. Requires that the History tool is included on your page.

So I guess the question to ask is how does 1.2.0 conflict with the code you already have? Post the errors and maybe even a demo of the problem would really help us troubleshoot the problem for you.

Answered over 6 years ago by Mottie