I just finished a web site and have noticed that when I go to view it in IE7 the navigation doesn't show up. I cross referenced the issue and the nav is working fine in Opera, Safari, and Firefox. I have tried several things including changing the font of the nav but still seem to be running into the issue. Forgive me if this is a ridiculous question but I'm still in school for web design and I haven't familiarized myself with this problem before. Thanks for all your help and suggestions you may have. I'm willing to try ANYTHING!

3 answers

danwellman 5600
1
point
This was chosen as the best answer

It seems to be the line-height:0; rule that is causing the text to be hidden in IE7. Take that off and the text becomes visible.

I also noticed a couple of other issues - you are floating the links inside the <li> elements and displaying the <li> elements as inline to get them to stack up. What you should do is float the <li> elements instead of the links.

Answered about 6 years ago by danwellman
danwellman 5600
1
point

To vertically align the menu, use a little margin-top on the <ul> or the individual <li>s, but <ul> would be best if possible :)

Answered about 6 years ago by danwellman
0
points

Thanks! That worked like a charm. Now I just need to figure out how to line it up in the middle of the nav. I also need to figure out the second part of your response.

Answered about 6 years ago by Tave
  • I can clarify the second part further, what else would you like to know? danwellman about 6 years ago