Hi...after NUMEROUS problems with IE7 not displaying many things properly, I've fixed, then narrowed them down to one overriding issue. Two of my four photos will not show up in it while they look fine in almost all other browsers and operating systems.

Does anyone know why this would be happening or how to fix it? It works OK (mostly) in IE6 and IE8 but just not IE7. I've tested them on Browsershots.

Could it be the DOCTYPE I'm using?

Here are the URLs:

http://www.lostinolympicnationalpark.com/book.html

http://www.lostinolympicnationalpark.com/bio.html

And the CSS: http://www.lostinolympicnationalpark.com/gawley.css

Thanks...I'll appreciate any help.

3 answers

0
points

The parent div element (#content) has a text-align: left - remove that, and your image re-appears in IE7

Now after doing this, obviously the text will align center in the body of the document, and just removing it from the body tag re-exhibits the invisible image problem, so I suspect there is something more within your stylesheet that may be an issue.

Sorry I couldn't be more help, but hopefully identifying the css element that is causing it will give you some grounds for investigation.

Cheers, Terry

Answered about 7 years ago by terry_brown
Nancy 0
0
points

Thanks.......but this is insane. I fix one thing and it produces another problem, every time. You're right in that taking that code away makes the pic reappear. So I put in-line codes to align left, and the photo disappears again. Well, actually, it shows a small part of it, making it even MORE confounding.

If anyone else has ideas, I'd sure appreciate hearing them. I'm about to go certifiably crazy.

Answered about 7 years ago by Nancy
Nancy 0
0
points

As a followup, I "fixed" it all by floating the photo to the right instead of the left. Why this was the problem, I'll never know, but there you go...........

Answered about 7 years ago by Nancy