fmz 14

Unfortunately, this issue has stuck to me longer than I care to think, but it must be resolved so I am back.

I am using the Sticky Footer approach get the footer to stay at the bottom of the page. It works in Firefox and Safari, but it simply refuses to stand its ground in IE7. I have been around and around with it and can't get it to stay on the bottom. In the cases where it does go to the bottom, it cuts off part of the content here.

I could really use a helping hand here to resolve this.

Thanks!

4 answers

Jordan 469
1
point

Try implementing this hack, courtesy of Ryan Fait, into the CSS code for the footer.

* {
    margin: 0;
}
html, body {
    height: 100%;
}
.wrapper {
    min-height: 100%;
    height: auto !important;
    height: 100%;
    margin: 0 auto -142px; /* the bottom margin is the negative value of the footer's height */
}
.footer, .push {
    height: 142px; /* .push must be the same height as .footer */
}

Here is a link to the hack.

Answered over 6 years ago by Jordan
  • I tried and I still get the same results. There is something else that appears to be causing the problems. fmz over 6 years ago
Jordan 469
0
points

Hmm...try adding height:100% into a conditional IE6 only style block. See here for more details.

<!--[if lt IE 7]>
<style type="text/css">
#wrapper {height: 100%;}
</style>
<![endif]-->
Answered over 6 years ago by Jordan
  • It is closer: http://www.ideapeoplesite.com/projectpath/jrs/our_history.html Now the footer is at the bottom, but for some reason part of the content is obscured at the bottom of the content area. fmz over 6 years ago
Jordan 469
0
points

The footer is "Sticking" to the bottom of your page now in IE7. Let's try changing the Doctype. Try changing it to: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

Answered over 6 years ago by Jordan
fmz 14
0
points

Alas this was more complicated than I realized. In addition I found that the

that was supposed to be enclosing all the content was closed prematurely. Once I got that fixed it came together. Thanks for all the help.

Answered over 6 years ago by fmz