I have updated agile carousel to use current version - beta 2.1.2 but it still has not fixed my problem. Is it something to do with the timer length and transition duration? Please help me!

2 answers

danwellman 5600
0
points

The carousel demo page doesn't seem to use jQuery UI and in your page you link to the carousel source file before linking to the jQuery UI sourcefile. As the carousel may depend on jQeury UI to smooth some of it's transitions this may be what is causing the problem.

Try changing the order of the sourcefile to this:

<script src="js/jquery.js" type="text/javascript"/>
<script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.5.2/jquery-ui.min.js"/>
<script src="js/jquery.easing-1.3.js" type="text/javascript"/>
<script src="js/carousel_behavior.js" type="text/javascript"/>

To be honest, jQuery UI 1.5.2 is pretty old now and the library has changed substantially since then. If changing the order of the script files doesn't fix the problem, I would advise that you look for another carousel - there are many of these available, most of which are not betas and work flawlessly...

Answered almost 11 years ago by danwellman
  • Thanks. I tried changing the order of the source files but no luck. Even tried same settings as the example on http://www.agilecarousel.com/examples/full_example. Can you suggest any other carousel which is similar? I'm looking for one which uses fade effect. Cheers Dwayne almost 11 years ago
  • start here: http://plugins.jquery.com/search/node/carousel+type%3Aproject_project danwellman almost 11 years ago
0
points

I'd recommend this one: http://malsup.com/jquery/cycle/

Answered almost 11 years ago by Tony Crockford