I uploaded the Contact Form 7 plugin for Wordpress on my site, and the entire form displays correctly with the exception of the submit button. I used the default settings for setting up a contact form, but I have no submit button. The page itself is at http://www.kettlerstrategyworks.com/?page_id=19. What is causing this problem and how can I fix it?

  • sorry if this is too simple a question, but in what css file is the new button style to be put? I've tried: <root>/wp-content/themse/arras-theme/css/styles/default.css <root>/wp-content/themse/arras-theme/css/mycss.css (the stylesheet particular to the site) So far, no dice. & just to be thorough, I have referenced the new style in the settings page for the form to: <p>[submit class:SignUpForEmailSubmitButton " "]</p> - O8 Orion about 6 years ago

2 answers

Doug 1095
1
point
This was chosen as the best answer

Because of this line in your stylesheet:

.widget_search .button, input[type="submit"], .widget_search .submit, #searchform input#searchsubmit {display:none;}
Answered about 6 years ago by Doug
  • Yep, youre right, so I deleted my answer. I saw that but I thought it was probably a JavaScript bug causing it to fail to clear. I cleard it inside my browser debug window and posted a message. Well see if Rafe saw it... Daniel Norton about 6 years ago
  • Thank you so much Daniel, now that I know what's wrong I've got it working. Rafe Kettler about 6 years ago
Orion 0
0
points

sorry if this is too simple a question, but in what css file is the new button style to be put? I've tried:

/wp-content/themse/arras-theme/css/styles/default.css /wp-content/themse/arras-theme/css/mycss.css (the stylesheet particular to the site)

So far, no dice. & just to be thorough, I have referenced the new style in the settings page for the form to:

[submit class:SignUpForEmailSubmitButton " "]

  • O8
Answered about 6 years ago by Orion